Mozilla has added all versions of Adobe Flash up to the most recent version 18.0.0.203 to the Firefox blocklist.

As Digital Theatre Plus uses Flash-based technology to deliver your shows, you may find that the player will not work if you are using Firefox as your browser.

You can manually download Adobe's newest version (18.0.0.209) of flash from the Adobe Website to view on Firefox. However, Digital Theatre Plus recommend utilising other browsers with Flash enabled to ensure smooth playback of your shows.